Resolvendo Problema: Configurando Eclipse + Proxy

Fala galera beleza? Tendo problemas para utilizar Eclipse + Proxy?

Tentou configurar nessa tela?: (Window > Preferences > General > Network Connections)
1
… e nada adiantou?

Problema: O eclipse não passa os parâmetros setados para JVM.

Solução: Passar os parâmetros diretamente:

Run > Run Configurations > Java Application > [Nome da sua classe Main] > Arguments
2

E na caixa “VM arguments” adicione o seguinte conteúdo:
________________________________________________
-Dhttp.proxyHost=hostNameDoProxy
-Dhttp.proxyPort=numeroDaPorta
-Dhttp.proxyUser=nomeDeLogin
(ou nomeDoDominio\nomeDeLogin)
-Dhttp.proxyPassword=senhaDoUsuario
-Dhttp.nonProxyHosts=localhost|127.0.0.1
________________________________________________

Fácil não é? Espero que tenha funcionado com vocês também… 😀

See ya!

Advertisements

About Gustavo Amaro

+ Formado em Tecnologia e Análise de Sistemas + MBA em Desenvolvimento de Aplicações JAVA – SOA

Posted on 12 de Dezembro de 2012, in Eclipse, IDE, Proxy and tagged , , , , , , , , , , , , , , , , , , , , , , , , , , , , . Bookmark the permalink. Deixe um comentário.

Deixe uma Resposta

Preencha os seus detalhes abaixo ou clique num ícone para iniciar sessão:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s

%d bloggers like this: